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DataLinker
 Making connections with Adobe InDesign

What does DataLinker do?
DataLinker allows you to connect an InDesign document directly to a data source, such as a database or a flat text file.  When 

a change is made to the data, you can automatically update the InDesign document to reflect the new information.  For any 

publication that may need to connect to external data, such as price lists, product catalogs, budgets, annual reports and the 

like, DataLinker is a powerful tool that will save time and reduce error.

Other features in DataLinker include:

•	 Simultaneously merge multiple records into an InDesign document

•	 Easily fill InDesign tables with data

•	 Create barcodes from database data (requires Teacup’s BarcodeMaker plug-in)

•	 Link images to image frames

•	 Automatically format text as it is placed to ensure continuity within your document.

•	 Automatically apply paragraph styles or object styles when your data is linked

•	 Regex find/replace on your data as it is placed in the document.  This allows for highly flexible data formatting

•	 Unlimited field length when using the ODBC plug-in. 

•	 Prefix and suffix areas in alphanumeric fields can handle all InDesign special characters, such as ^n for a 
carriage return, and ^t for a tab.

•	 Use XML rule scripts to modify data after it is merged into the document, using the full power of the InDesign 
scripting API.

How do I use DataLinker?
There are four main steps required to begin using DataLinker

1.	 Add a data source using the DataLinker palette

2.	 Layout the InDesign document where the data will be placed

3.	 Place or merge the data from the data source to your InDesign document.

4.	 Synchronize the data from the data source as necessary.

Thanks for using Teacup Software’s DataLinker!  A fast and 

efficient way to connect databases to Adobe InDesign, 

DataLinker allows users to link comma separated value 

(CSV) files and, with the ODBC add-on, ODBC databases to a 

document. Once the data source is linked, updates are quick 

and easy to perform.  Ideal for anyone working in catalog 

publishing or with price lists, DataLinker allows an unlimited 

number of data sources to be added to an InDesign 

document for flexible data management. Simple-to-use, one 

palette controls all of the plug-in’s capabilities and with just a 

few clicks, data is connected.
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Using this Manual
This manual is intended as an overview of all the features in DataLinker.  It is intended as a reference manual for the features.  

Teacup also provides four step-by-step walkthrough tutorials, along with a PDF document to guide you through them.  They 

are installed with DataLinker, under the InDesign folder > Plug-ins > Teacup > DataLinker.  We encourage you to use those as 

a starting point for learning all the features as they might be used in a real-world situation.

Adding, Editing and Deleting Data Sources
Once DataLinker is installed, you will be able to create data sources connecting InDesign to CSV or ODBC-based data.  Once 

you add the data sources, you lay out your InDesign document as you would any normal document, keeping in mind where 

the data may be placed or merged in.  When you are ready to place data from a data source, use the DataLinker palette to 

add in the data.  You can also merge multiple records from a data source into an InDesign text frame or table.  Once the data 

has been placed in the document, you can synchronize the document with the data source at any time for quick updates.

What is a Data Source?

A data source is the place where your information comes from.   If you are laying out a book catalog, it may be a MySql 

database that has all the pricing information, product descriptions, cover snapshots and ISBN codes.  If you are automatically 

laying out a course catalog, it may be a CSV file that has all of the course description, location and schedule information.  

DataLinker currently supports two kinds of data sources: comma separated value (CSV) files and ODBC databases (requires 

the ODBC add-on).

To link to data from a data source, you first need to let DataLinker know 

where the data source is and how to connect to it.  That process is 

called “adding a data source.”  Let’s take a look at how to add a CSV or 

an ODBC data source to DataLinker.

How to Add a CSV Data Source

The term “CSV” is short for “Comma Separated Value.”  DataLinker can 

actually handle text files whose fields are separated by commas, tabs or 

semi-colons, but the file must always end with the suffix “csv”.

To add a CSV data source, follow these steps:

1.	 From either the palette flyout menu or the main DataLinker menu, choose Data Sources > Add Data Source.

3.	 A small dialog appears asking you what type of data source you would like to add.  Choose “CSV” and click “Next”

4.	 The “Add CSV Data Source” dialog appears.  The dialog is broken down into three areas:
•	 Data Source Name - Type in the name of your data source.  This is the name that DataLinker will use to refer to 

your data source.

•	 Location - Click the Choose button to browse to the CSV file you want to use.  Remember, the file must end 
with a .csv suffix!

This dialog appears when you first add a 

data source.
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•	 Content – In this area, 
DataLinker needs to know how 
to read your text file.  Is the file 
Unicode or ASCII?  What line endings 
are used?  What kind of record 
delimiters?  The following are the five 
fields in this area you can set:

1.	 File Encoding – Select ASCII 

or Unicode.

2.	 Record Delimiter – Choose 

the character that marks the end 

of a line in your text file.  Select CR 

(carriage return), CR/LF (carriage 

return/ line-feed) or LF (line-feed).  

Different platforms (Macintosh versus 

Windows, for example) will save their 

files using different line ending types.

3.	 Field Delimiter – This lets 

DataLinker know what characters - 

comma, semi-colon or tab - to look 

for between each field in a given 

record.

4.	 Text Qualifier – Fields may be surrounded by single or double quotes, or by nothing at all.  Select what best applies 

to your data file.

5.	 Key Field – This is where you tell DataLinker which field it should use to uniquely identify each record.  It is 

important that this field will never change for a given record, and that no two records share the same key.

6. 	 Sample – Please note that this area at the bottom of the dialog shows how DataLinker reads the first eight fields in 

the data source.  As you change the various settings in the “Content” area, this sample field will update to show how 

DataLinker reads the data with the different settings.

How to Add an ODBC Data Source

ODBC is the acronym for Open Database Connectivity, a Microsoft Universal Data Access standard.  Since its inception 

in 1992, it has become the industry standard interface for developing database-independent applications.  As long as a 

database provides an ODBC driver, ODBC compliant applications such as DataLinker can connect to the database.  On 

Windows, most drivers are readily available either from Microsoft or from the database vendor.  On the Macintosh, you may 

need to purchase a third-party ODBC driver, as well as install the iODBC libraries.  See the “Adding ODBC data sources on the 

Macintosh Platform” section below.

Add File Data Source dialog A. Data source name B. File location C. File 
encoding D. Record Delimiter E. Field Delimiter F. Text Qualifier G. Key 
Field selection H. Data Sample

B

C

D

E

F

G

H

A
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The first step in creating an 

ODBC data source is to create 

a Data Source Name, or DSN.  

You perform this process using 

operating system utilities.  You 

can launch the dialog to create 

your DSN from within DataLinker, 

but it is advisable to create your 

DSN on your own first.  Once you 

have created your DSNs using 

native operating system utilities, 

you can connect to those DSNs 

with DataLinker by following 

these steps:

1.	 Choose Data Sources 

> Add a Data Source 

from the DataLinker 

menu.

2.	 A small dialog appears 

asking you what type of data source you would like to add.  Choose “ODBC” and click “Next”

3.	 The “Add ODBC Data Source” dialog appears.  These are the fields that you need to specify:

•	 Name - Type in a name to refer to your data source in DataLinker. This is distinct from the DSN you create in the 
operating system.

•	 Choose - Click this button to bring up the OS-native dialog that will allow you to choose or create an ODBC 
DSN on your operating system.

•	 SQL Query - The Structured Query Language (SQL) is the standard language used to query and manipulate 
data in databases.  You can create a query that pulls data from multiple tables into a single data source.  When 
you select a table in the Table Name dropdown, DataLinker will automatically create a simple SQL query to 
retrieve the data from the database, and the query will be entered here.  If you want to be more specific about 
the data you get, type in your own SQL query.  You can compose your query in another application and simply 
paste the text in here.

•	 Cache Size – Data linker caches a certain number of records in memory for display in the DataLinker palette, 
and for merging.  This field determines the size of the cache.

•	 Run Query - Click this button to retrieve the records with information specified in your SQL query.

•	 Table Name - This dropdown lists all the tables that exist in the database you are connecting to.  Choose the 
table you would like to refer to here.  Choosing a table from here will overwrite any SQL query you may have 
specified.

Add File Data Source dialog A. Data Source Name B. Choose ODBC data 
source button C. SQL Query Text D. Run SQL Quey button E. Size of the 
record cache F. Table List G. Text encoding list H. Key Field I. Data Sample

F

G

I

B

D

A

C

E

H
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•	 Text Encoding – Choose the type of encoding that the ODBC driver will use to deliver the data.

•	 Key Field - This is where you tell DataLinker which field it should use to uniquely identify each record.  It is 
important that this field will never change for a given record, and that no two records will share the same key.

More About ODBC Data Sources on the Windows Platform

Many ODBC drivers come installed with Windows or are installed automatically with their host application.  For example, 

linking to a Microsoft Excel file on Windows requires no special software, and creating a DSN that points to a specific Excel 

file is a fairly straightforward process.  For information on installing drivers to allow you to create DSNs for other database 

types, you may need to contact the database vendor.

More About ODBC Data Sources on the Macintosh Platform

You will need to download and install the open source iODBC libraries and driver manager for the Macintosh from http://

www.openlinksw.com/download. Downloading any driver from OpenLink will also install the iODBC libraries and the 

manager application, or you can install the SDK for the libraries and driver manager alone. 

The iODBC libraries are the basis for using ODBC connectivity on the Macintosh.  However, each database requires its own 

specific ODBC driver, often included with the database by the database vendor.  For example, FileMaker has an ODBC driver 

for the Macintosh designed specifically for their database.  Other databases, such as the open source MySql database, might 

require that you purchase a separate ODBC driver from an outside vendor.  Two such vendors are listed below.  Teacup does 

not endorse either vendor, but merely provides their names as a reference.

http://www.openlinksw.com/

http://www.actualtechnologies.com/

For more information about using ODBC data sources on the Macintosh, OpenLink has an excellent FAQ on their website.  

This FAQ also details how to set up a FileMaker database as an ODBC data source.

http://support.openlinksw.com/support/mac-faq.html

How to Edit or Delete a Data Source

To edit a data source, from the DataLinker or palette flyout menu choose Data Sources > Edit Data Source and then choose 

the field to be edited.  The dialog to edit a data source is identical to the dialog to add a data source, except the data source 

name is disabled.  There is also a “Delete” button here, which you can click on to delete a data source. 

 Note: if you delete a data source, that doesn’t delete data that has been linked to a document.  Once a data source 

has been deleted, you won’t be able to synchronize the data in the document any more.

http://www.openlinksw.com/download
http://www.openlinksw.com/download
http://www.openlinksw.com/
http://www.actualtechnologies.com/
http://support.openlinksw.com/support/mac-faq.html
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Using Multiple Data Sources in the Same Document
It is easy to link data from multiple data sources to a single document.  First, you need to have multiple data sources added.  

Then, activate your data source by using the flyout menu from the palette or the main DataLinker menu, or from the 

dropdown on the DataLinker palette.

Add the data to the document from your first data source.  Once you are done, activate another data source, and add data to 

the document from the second data source.  Now, when you synchronize data from the document, data will be synchronized 

from both data sources at once.

Where Are Data Sources Stored?
Data sources are shared by all documents in an application.  Information about your data 

sources is placed in a file called DataLinker.xml, stored in your InDesign preferences folder.

Sharing Data Sources

You can share data sources with your colleagues by sending them the DataLinker.xml file 

and having them place that file in their DataLinker folder under their preferences folder.  

You will need to quit and restart InDesign in order for your data sources to load.

Using DataLinker to place data
After a data source has been added and activated, the data will appear in the DataLinker 

palette.  You can sort through your data either using the navigation arrows located at the 

bottom of the palette, or by typing the key record into the record dropdown widget at the 

Multiple data sources have been added here.  We are going to activate one of them.  The 

data source with the check mark is the one that’s already active.

Scroll through your data using 

either the Record: dropdwon (top) 

or the arrow buttons (bottom)
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top of the palette.  You can also dropdown that menu item and scroll through the key fields in your data.

Once you have your record selected in the DataLinker palette, you can place the data into your InDesign document by going 

through the following steps:

1.	 Choose the field you wish to insert.  In the DataLinker palette, each item in the listbox represents a field in the 

database record.

2.	 For inserting text fields, have a text selection active in your InDesign document.  For inserting image fields, you can 

either have the text selection active (to insert inline images) or a graphic frame selected (to insert an image into 

that frame)

3.	 Click on the “Insert Field” button in the lower left of the DataLinker palette.

4.	 The data will be inserted into your InDesign document.  It will be marked by non-printing brackets at the start and 

end of the data.

Note: you can also insert a field by choosing “Insert Field” from the palette flyout menu, or by double-clicking on the row 

in the listbox.

Now that the data exists in your InDesign document, it can be updated from the database at any time by either synchronizing 

an individual field or by synchronizing the entire document.  See the section below, “Synchronizing Data” for more information.

Using DataLinker to merge data
You can use DataLinker to link data from multiple records into a text frame or a table.  This process is called merging, and it’s 

a simple yet powerful feature in DataLinker.

To merge data into a text frame using DataLinker:

1.	 In your InDesign document, place the cursor where you would like the first field to appear.

2.	 Double-click on the field in the DataLinker palette.  The field value for the current record will appear in the text 

frame, surrounded by non-printing brackets.

3.	 Repeat for as many fields as you would like to merge.  

Note: You can only merge records from the same data source.  If you highlight records from multiple data sources, you 

won’t be able to merge.

4.	 Once all the fields are inserted, highlight all the text that you would like repeated for each record.  This could 

include both fields from a data source and simple text.  Note that all highlighted text will be repeated for each 

record when doing a merge.  Therefore, it is important to only highlight text intended for merging.

5.	 Select the “Merge” menu item from the flyout menu in the DataLinker palette.

6.	 DataLinker will present you with a dialog where you can decide what records to merge in.  Type the record 

numbers for the first and last record you want merged.  Click OK.

7.	 DataLinker will now merge in all selected records from the database, repeating any highlighted text.  DataLinker will 

preserve all formatting from the existing text when inserting new text from database records.
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To merge data into a table using DataLinker

You can use DataLinker to automatically fill an InDesign table with data from a database.  You can format the table using 

table and cell styles, and DataLinker will maintain those styles as it merges data into the table.

1.	 Insert the field names into the cells where you wish the data to be merged.

You can insert a single field per cell, multiple fields per cell, or just plain text in a cell, as you desire

2.	 Highlight the cells containing the fields you want to merge.

You can select fields in more than one row, as well as merged cells in the table.  When merging the data, DataLinker will 

copy as many rows as you have selected and reproduce them for every record.  You can have a single record in two, three or 

more rows of a table, and you can take full advantage of InDesign’s table formatting abilities to merge and split cells as well.

3.	 Select the “Merge” menu item from the flyout menu in the DataLinker palette.

4.	 DataLinker will present you with a dialog where you can decide what records to merge in.  Type the record 

numbers for the first and last record you want merged.  Click OK.

5.	 DataLinker will now merge in all selected records from the database.  All text and table formatting will be used from 

the existing table cells when inserting new records from the database.

Autoflowing Merged Data

When you flow a lot of data into a single text frame, it may become overset.  You can autoflow the overset onto new pages 

using InDesign’s autoflow feature.  Click on the out port of the overflowed text frame.  Your cursor will turn into the loaded 

text icon .  Hold down the shift key and the icon becomes the autoflow icon . Now click on a new page and InDesign 

automatically adds the pages needed to hold the text.

 Note: InDesign CS4 has a new Smart Text Reflow feature that will automatically create new pages if a frame overflows 

with text.  It works best with master pages, and you need to enable it (under Preferences > Type).  If you have it 

enabled in CS4, new pages will be created automatically when you merge, and you won’t need to autoflow the 

overset text.

Synchronizing data
You can update the text in a document from a data source on either a field by field basis or across a whole document.

•	 Synchronize Field - Select the field or fields you would like to synchronize by highlighting text containing the 
data field in your InDesign document. When the text is highlighted, click on DataLinker’s “Synchronize Field” 
button in the lower left hand corner of the palette.  Any changes made in the data source will be automatically 
updated in your document.

•	 Synchronize Document - Click on DataLinker’s “Synchronize Document” in the lower left hand corner of the 
DataLinker palette to have new information from all fields in the data source updated throughout the entire 
InDesign document. 

Note: There are also menu items for Synchronize Field or Synchronize Document in the flyout menu of the 

DataLinker palette, as well as under the DataLinker menu.
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The Importance of the Key Fields for Synchronizing Data

The key field that you define when creating a data source is critically important when synchronizing data.  DataLinker looks for 

that key field in the data source in order to synchronize.  If the key field ever changes for a record, DataLinker won’t be able to 

synchronize any more.  This is why it is important to choose a key field whose data will never change in the data source.

Merging Data onto Master Pages
If you want data to flow from one frame to another on the same page, create linked text frames on your master page.  

Insert your data from DataLinker, and jump from one frame to the next using column breaks.  Then, you can use InDesign’s 

autoflow feature to flow your data into the master page text frames and automatically create pages as needed.

To Merge Data onto Master Pages

1.	 Go to your master page and create all the text frames that will contain your data.  

 Note: Do not put data from a DataLinker data source on the master page. Just create and link the frames that will 

contain your data, but leave the frames empty.  Data that is static, that is not coming from a DataLinker data source 

and will be the same for all records, can be put onto the master page

2.	 Now apply the master page to the last page of your document.

3.	 On the document page, you will see that the text frame from the master page has a dotted outline, and that you 

can’t select it.  To be able to select it, you have to pull it from the master page to the document page.  To do this, 

click on it while holding down Ctrl/Command-Shift.  This will let you edit the master page item on your document 

page.  The outline should become solid (as opposed to dotted) when it is pulled from the master page to the 

document page.

4.	 Open up the DataLinker palette.  Insert fields into each frame where you want data from DataLinker to be merged 

into.  Insert a column break at the end of each frame to jump from one frame to another.

5.	 Put your text cursor in the first text frame and Select All (Edit > Select All or Ctrl/Cmd-A).

6.	 Show the DataLinker palette and select Merge from the flyout menu.

7.	 In the choose records dialog, choose the records you want to merge in and click OK.

8.	 The records will merge into the text frames on this page, causing an overflow.  Click on the out port of the 

overflowed text frame.  Your cursor will turn into the loaded text icon .  

9.	 Add a new master page to the end of the document. Your cursor should still show the loaded text icon.

10.	 Hold down the shift key and the icon becomes the autoflow icon . Click on the first master page text frame 

and all of the text will flow into your master page text frames, adding new text as needed. 

 Note: InDesign CS4 has a new Smart Text Reflow feature that will automatically create new pages if a frame overflows 
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with text.  You need to enable it (under Preferences > Type) for it to work.  If you have it enabled in CS4, new pages 

will be created automatically when you merge, and you won’t need to autoflow the overset text.

Creating Barcodes Automatically with BarcodeMaker
DataLinker allows you to create barcodes from data in a database.  Once you edit the field and define it as a barcode, 

DataLinker will work with BarcodeMaker to create a barcode from the database data.  You can also link multiple fields to the 

same barcode.  See the section below called “Settings for barcode fields” for more information.

Formatting data fields automatically
DataLinker can automatically format text as it is placed into a document according 

to settings created for each field.  To define formatting settings for an individual field:

1.	 In the DataLinker palette, select the field whose settings you want to edit.

2.	 Select “Edit Field” from the from the right click menu  or the flyout menu 

in the DataLinker palette.

3.	 A “Field Options” dialog will pop up.  Select the type of data in this field.  

Your options are Alphanumeric, Numerical, Currency, Percent, Image and 

Barcode (requires BarcodeMaker).  Each data type offers its own settings, 

which we’ll talk about further down.

4.	 Once you have chosen all your settings, click OK.

5.	 Now, every time you insert data or field names from the database, the 

formatting settings defined for that field will be used.

Settings for alphanumeric fields

Alphanumeric is a catch-all phrase for generic text.  These are the settings you can use when setting up an alphanumeric field:

•	 Strip Whitespace – if checked, DataLinker will remove any 
“whitespace” (spaces and tabs) that occur in the database before and 
after the data and then insert the data into the InDesign document.

•	 Hide Prefix/Suffix if empty – If checked, DataLinker will hide the text 
in the prefix and suffix fields if there is not data coming from the 
data source for this record.

•	 Character Style – This dropdown lists the character styles defined 
for a document.  Choosing one will cause DataLinker to apply the 
character style to the data when it is placed into the document.

•	 Prefix – DataLinker will prepend the text entered here to the data 
when it is placed into the document.  

•	 Suffix – DataLinker will append the text entered here to the data when it is placed into the document.

•	 Regex Find String – a GREP regular expression that will search the incoming data.

Right click on a DataLinker field 

to edit it. You can also select “Edit 

Field” from the DataLinker menu.

Field options for Alphanumeric fields
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•	 Regex Replace String – a GREP regular expression that will replace data found by the Regex Find String..

Note: In the Prefix and suffix fields, you can use any of the special characters that are available in the Text tab of 

InDesign’s Find/Change dialog.  For example, ^t is a tab, ^p is a paragraph break, and so forth.  You can see all the 

special characters available to you by looking in InDesign’s Find/Change dialog.

Note: In the Regex fields, you can use any of the special characters that are available in the GREP tab of InDesign’s 

Find/Change dialog.  For example, you can use \t for a tab, or ~8 for a bullet character.

Note: You can use suffixes in conjunction with the “Hide Prefix/Suffix if empty” option to completely hide an empty 

field.  Instead of putting your return character in the document, you can place it in the suffix field using the ^p 

special character.  Then, if you check “Hide Prefix/Suffix if empty,” you will avoid a blank line if the field is empty.

Settings for Numerical Fields

The settings for numerical fields are identical to alphanumerical fields, except that “Strip Whitespace” is replaced by “Decimal Places.”

•	 Decimal Places – The number of decimals that DataLinker will require to appear after the number when placed 
into an InDesign document.

Settings for Currency Fields

The settings for currency fields are identical to alphanumerical fields, except 

that “Strip Whitespace” is replaced by “Currency Symbol.”

•	 Currency Symbol – Place the symbol you would like to use.

•	 Force Decimals – If selected, DataLinker will append two decimal 
places to the numbers, even if they don’t exist in the database. 

Settings for Percent Fields

The settings for percent fields are identical to numerical fields.  The only difference is that the percent sign will be appended 

to the end of the data.

Settings for Image Fields

You can insert images from a database using DataLinker.  An image will be inserted inline into the text stream, and you can 

select an object style to define how the image is anchored.  The database field must contain the exact name of the image to 

be used, and all images that a field refers to must reside in the same directory.

•	 Object Style – Choose the object style that will be applied to the 
graphic frame.

•	 Picture Format – Use these options to fit an image and its 
containing frame together.  Your options include Top Left, 
Fit Frame to Content, Fit Content to Frame, Fit Content 
Proportionally, Fit Frame Proportionally, or Center Content.

•	 Image Location – Click on the Choose... button to navigate to 
the directory containing the images.  This will be the full path to the directory on your hard drive.

Field options for Currency fields.

Field options for Image fields.
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Settings for Barcode Fields

If Teacup’s BarcodeMaker and PatternMaker plug-ins are present, you can have DataLinker automatically insert a field as a 

barcode.  The data in the field will be encoded by the barcode of your choice.

•	 Object Style – Choose the object style that will be applied to the 
inline or anchored graphic containing the barcode

•	 Picture Format – Use these options to fit an image and its containing 
frame together.  Your options include Top Left, Fit Frame to 
Content, Fit Content to Frame, Fit Content Proportionally, Fit Frame 
Proportionally, or Center Content.

•	 Barcode Type – Choose the type of barcode that will be used to 
encode the data.  You have over 20 barcode types to choose from.

•	 Configure – Brings up the “Configure Barcode” dialog that allows you 
to map multiple database fields to multiple barcode parameters.   See “Configuring a Barcode” below.

•	 Regex Find String – a GREP regular expression that will search the incoming data.

•	 Regex Replace String – a GREP regular expression that will replace data found by the Regex Find String..

Note: The Regex fields are useful for when the barcode data in the database is formatted in a way that 

BarcodeMaker won’t accept.  For example, if you have a bunch of EAN 13 barcodes in your data source, but they 

have a dash somewhere in the barcode, BarcodeMaker won’t be able to encode the barcodes because of the dash.  

You can use the Regex Find/Replace strings to remove the dash before the data goes into BarcodeMaker.

Configuring a Barcode

Barcodes in BarcodeMaker have a number of different parameters that can be set, including things like whether a check 

digit is displayed, what kind of font is used for the human readable text, and so forth.  You can see all these options in 

the PatternMaker palette when you create a barcode.  There are some cases where you may want to set some of these 

parameters from data in a database.  The ISBN barcode has a good example of this.  In addition to the 10 or 13 digit number 

that makes up the barcode itself, most publishers also add a five-digit suffix barcode that often indicates a book’s retail price.

To use the “Barcode Configuration” dialog to map barcode parameters to fields in your data source:

1.	 Select the barcode parameter you want to map to in the “Barcode Parameter” dropdown.

2.	 Select the field you want to pull data from in the “Datasource Field” dropdown.

3.	 Click the “Add” button.  The two fields will appear in the list of mappings below.

4.	 Click OK to accept these settings.

What this means is that when the barcode is created, in addition to creating a barcode based on the main field in the 

database, DataLinker will use the settings you choose in this dialog to set additional parameters in the barcode.

Field options for Barcode fields
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DataLinker and XML
DataLinker is built on top of InDesign’s native XML functionality.  When you insert a field from 

DataLinker into an InDesign document, that text is given an XML tag with attributes that 

allow DataLinker to later synchronize the field.  You can see the XML structure that DataLinker 

creates by showing the Structure Pane.  To view the Structure pane, choose View > Structure 

> Show Structure..  See InDesign’s help file for more information on the Structure pane. Text 

data from DataLinker is stored under a tag named “teacup-tag.”

Merging into existing XML

DataLinker respects existing XML tags.  For example, if you are trying to merge DataLinker 

data into text that is already tagged with a tag “headline”, DataLinker will create its own 

“teacup-tag” underneath “headline.” .

Looking at the XML Tree

You can always look at the XML tree in an InDesign document by choosing View > Structure 

> Show Structure.  The XML tree is a good place to troubleshoot.  It’s possible that you might have deleted some text without 

deleting the surrounding tags, or that you might have put tags within tags, and the structure tree is the place to look. 

Deleting Unused XML Data

If you merge some elements into a story, and then delete the story by deleting all the text frames the story flows into, 

the XML elements that DataLinker creates will still be sitting in the XML pane, even though they no longer correspond 

to anything on the page. These unplaced elements can slow down DataLinker when synchronizing data.  The menu item 

“Remove Unused XML Data”, available from the palette flyout menu  and from the DataLinker menu, will go through the XML 

tree and delete any DataLinker XML elements that are not placed on a page.

DataLinker Utilities
Starting with the InDesign CS5 version of DataLinker, there is a new Utilities menu that offers a variety of functionality.  

Data Sources > Export Data Sources

This will export your data sources to a file called DataLinker.xml to a location of your choosing

Data Sources > Import Data Sources

This will import a set of data sources from a DataLinker.xml file. Note that any existing data sources that have the same name 

as an incoming data source will be overwritten by the incoming data source.

Data Sources > Reload Current Data Source

This will cause the DataLinker palette to refresh the currently loaded data source

An example of the XML 

structure that DataLinker 

creates.
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Document > Rename column-name in doc

This allows you to rename a field in a document.  Useful if you have already merged data into a document but have changed 

the name of the column in your data source.  Also useful if you want to merge different columns into the same template - 

you can create the template using one column, and when you want to switch, you can use this utility to rename the column 

in your document and then just refresh the data.

Document > Rename data-source in doc

If you have a data source whose name has changed, you can use this utility to modify any place where data has been 

merged using the old data source name to use the new data source name.

Document > Update One Column

This utility will update all instances of a single field in a document.

Document > Update Only Images

This utility will update all image fields in a document

Document > Update Only Non-Images

This utility will update all fields that are not images in a document.

Creating new utilities
All of the functions in the Utilities menu are created using JavaScripts, and the scripts are available for you to read and 

modify.  You can find them in the your InDesign folder, under Scripts > DataLinker.  

If you want to create a new utility, the first step is to write a script.  We suggest creating a copy of one of the existing scripts 

and using that as a starting point.  Once you’re done writing the script, drop it into the Actions folder (InDesign > Scripts > 

DataLinker > Actions).  Any subfolders under the Actions folder will be mirrored as a submenu in the Utilities folder.  Note 

that the Utilities menu is created on startup, so if you create a new script you’ll need to restart InDesign to have it show up in 

that menu.

Scripting and DataLinker
With InDesign, it’s easy to create a script that modifies DataLinker elements using an InDesign feature called XML Rules.  An 

XML rule is a block of scripting code that defines three elements:

1.	 A name (as a string).

2.	 A condition (as a string).

3.	 An action (as a scripting function).

The condition string uses the XPath specification to match elements according to their tag names, their attributes, or their 

siblings.  The action is a script function that is passed the XML element as a parameter.  All of the examples we show here are 
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written in JavaScript, but you can also write XML Rule scripts using AppleScript or VBScript.

Since all of DataLinker’s elements are merged into the document as an XML element with attributes to identify the data 

source and the column from the database, you can use the condition part of the XML rule to find items from a specific 

column in your data source.  You can then use the action to check the actual content of the data and take an action 

depending on the data.  You have the full power of InDesign’s scripting API to do whatever you want to the document itself.

You can create any number of XML Rules to operate on your DataLinker data.  Once they are created, you collect them 

together into a rule set and run the rule set on the set of XML elements you would like to modify.

// This file is provided by Adobe, and can be found in InDesign’s Scripts folder
#include “glue code.jsx” 

// This example has one rule, but you can have as many as you want
// in the array
var myRuleSet = new Array(new RuleName);

var myDocument = app.documents.item(0);

// process the rule set on an XML node, in this case the root node
__processRuleSet(myDocument.xmlElements.item(0),myRuleSet);

Here is the sample XML rule:

function RuleName() {
	 this.name = “RuleName”;
	 this.xpath = “//teacup-tag[@column-name=’department’]”;
	 this.apply = function (element, ruleSet, ruleProcessor){
		  //Do something here.
		  //Return true to stop further processing of the XML element
		  return true;
	 }; // end of Apply function
}

Details of how to write an XPath condition and examples of actions are all contained in InDesign’s scripting guide.  Here is 

a hyperlink to the scripting guide, and here is a hyperlink to Adobe’s scripting support page), where you can get detailed 

documentation and examples of using XML Rules.  You can also see the fourth walkthrough in our samples for a functional 

example of how to use XML Rules with DataLinker.

http://wwwimages.adobe.com/www.adobe.com/products/indesign/scripting/pdfs/InDesignCS3_ScriptingGuide_JS.pdf
http://www.adobe.com/products/indesign/scripting/
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Installing Your Teacup Plug-in
To install your Teacup plug-in, simply double click on the installer and it will install the plug-ins, documentation and support 

files (including this documentation file) into your InDesign Plug-ins folder, under a folder called “Teacup”.  To uninstall your 

plug-ins, you will need to remove them from the “Plug-Ins” directory wherever you have InDesign installed.  All Teacup plug-

ins will be installed into a “Teacup” folder under your “Plug-ins” directory.

Activating Your Teacup Plug-In
When you purchase a Teacup plug-in, you are sent a serial number that you then use to activate the demo version to be the 

full working version.

Please note that you must be logged in as an administrator to activate or purchase the plug-in.

Activating using the Internet

1. There are two ways to start the activation process
·	 From the plug-in’s splash screen, you can press the “Activate” button

·	 From the Help > About Plug-Ins menu (Win) or InDesign > About 
Plug-Ins menu (Mac), select Teacup > [plug-in name] > Activate

2. A dialog will appear that has two sections to it.  In the first section, 

you enter your activation key.  In the second step, you click “Activate 

Automatically.”  This will connect with Teacup’s servers, check if the serial 

number is valid, and if it is, will unlock the plug-in.

3.	 When you’re finished activating, click the “Done” button to dismiss the dialog.

Activating Manually

Some networks have firewalls or proxies that don’t allow the plug-in to activate with Teacup’s servers.  To get around this, 

we offer a manual activation process.  To activate manually, follow all the steps outlined above, but before clicking on the 

“Activate Automatically” button, disconnect or deactivate your Internet connection.  The plug-in will detect that there is no 

connection, and a wizard will launch to allow you to manually activate.  The wizard will guide you through the process.

Deactivating your Teacup Plug-in

If you want to move your plug-in from one machine to another one, you need to first deactivate the machine you have 

already activated.  To do this, go under Help > Deactivate Teacup Plug-in and select the plug-in you would like to deactivate. 

The product activation dialog.
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