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PatternMaker and PatternPack
Powerful Postscript Patterns for InDesign

Quick Start Guide
If you’re like us, you want to get up and running as fast as 

possible. Here’s what you do:

1. Install PatternMaker. The installer will put the plug-

in inside the Plug-ins folder, in your InDesign folder.

2. Launch InDesign, open a document, and select any 

empty frame or path.

3. If you don’t see the PatternMaker palette, select 

Window > PatternMaker.

4. Choose a pattern from the palette’s popup menu 

and click the Apply Pattern button.

5. Now go wild changing the various options in the 

palette. Each time you make a change, the pattern 

updates on screen.

More Information

What It Does

PatternMaker lets you fill any page item with a pattern.  

Just select the page item, choose your pattern from the 

PatternMaker palette, and push the Apply Pattern button. 

Now’s where things get interesting.  Once the pattern is applied to your frame, the PatternMaker palette gives you a custom 

set of controls you can use to change the pattern. Experiment with the different changes you can make to your pattern!

Thanks for using Teacup Software’s PatternMaker!  Designed 

by page-layout guru David Blatner, the PatternMaker brings 

high-quality PostScript graphic patterns to Adobe InDesign. 

The PatternMaker lets you fill any InDesign frame with a 

pattern and then make an almost unlimited variety of changes. 

With a different set of controls for every pattern, each 

pattern included in this package offers a different worlds of 

design possibilities!

Custom 
controls for each pattern! The PatternMaker palette for the 
Crosses and Lines patterns.
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Pattern PossIbIlItIes — an examPle

Here’s just one example of the versatility of just one of the available patterns, the seemingly simple Squares pattern:

hoW It Works

When you add a pattern to a frame, PatternMaker builds a PostScript graphic and places it as an image inside the frame. The 

page item is still a normal InDesign page item — you can still do all the things you’re used to doing to any other page item, like 

applying a fill, scaling, and changing the shape.

The pattern graphic is embedded in the document itself, so you never have to worry about keeping track of it or sending it 

separately to your printer. Don’t worry, embedding these patterns adds very little to your document size (only a few K) and 

embedding graphics in InDesign is very safe (see “Unembedding Patterns” for more on this).

Because these patterns are just graphics, you can send your documents to anyone, even if they don’t have this plug-in.

Patternmaker anD PatternPack

PatternMaker is a free plug-in that comes with three pattern.  PatternPack is a paid plug-in that adds an additional thir teen 

patterns to PatternMaker.  You’ll need PatternMaker to use the patterns in PatternPack.

➜➜ ➜➜ ➜➜
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Pattern Presets

PatternMaker now offers Pattern Presets, a simple way to save all of 

your pattern settings into a single preset setting.  When you apply the 

preset, all of the pattern parameters are applied at once.

Using PatternMaker

aPPlyIng a Pattern

When you select a frame without a pattern, the PatternMaker palette 

only has the pattern type dropdown.  Choose a pattern from the 

dropdown and click the Apply Pattern button, and the pattern shows 

up on your frame. You can also select more than one frame or path at 

a time. Note that if you select a frame that already has content (text 

or another graphic), PatternMaker warns you that the contents will be 

deleted if you proceed.

moDIfyIng a Pattern

Changing a pattern is easy: Just select the frame that has a pattern applied to it, make a change to any of the controls, and as 

soon as you press Tab or Enter, the pattern updates, just like any other control in InDesign.  You can also press the Up or Down 

Arrow keyboard keys within any number field. If you want to change the pattern entirely, just select the frame and choose the 

new pattern from the Pattern Type popup menu. The new pattern is immediately applied.

aPPlyIng transformatIons to a Pattern

You can modify PatternMaker patterns just like you would any other 

placed graphic in InDesign. For example, you can rotate it, scale it, 

mirror it, or skew it.  To make changes directly to the pattern, such as 

scaling or shearing, select it with the Direct Select tool.

However, we recommend selecting the entire frame with the Selection 

tool and rotating or scaling that instead. The reason: After you 

transform the pattern inside the frame, it may no longer stretch to the 

boundaries of the frame.
Patterns with (from left to right) skew, feather, 
and drop shadow applied to the pattern itself

The PatternMaker palette in its default state.
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aPPlyIng effects to a Pattern

Because these patterns have transparent backgrounds (that is, you can see through the spaces between the pattern lines), you 

can add a background color to the pattern by changing the fill color of the frame. Plus, you can all of the effects available in 

InDesign to the patterns! However, the result depends on which selection tool you use and the fill color of the pattern’s frame. 

If the frame has a fill color of None, then applying the effect always affects the pattern itself. If the frame has a solid color (or 

gradient) fill, then you must first select the pattern with the Direct Selection tool (white arrow) tool. Otherwise, the effect is 

applied to the frame rather than the pattern.

Pattern colors

When applying colors in the PatternMaker palette, you can choose from any CMYK swatch in your document. Changes you 

make to the swatch are updated across all patterns. Only CMYK swatches are supported in this version.

DIsPlay QualIty

Some of these patterns can be calculation intensive! For example, complex spirals may take a while for InDesign to display 

on screen. If InDesign bogs down too much, consider selecting the pattern with the Direct Selection (white arrow) tool 

and choosing Object > Display Performance > Optimized Display. The image will become greeked on screen, but will print 

properly.

Sometimes patterns don’t appear as precisely on screen as you’d like. In that case, try these three techniques. First, select the 

frame (with the Selection tool) or the pattern (with the Direct Select tool) and choose Object > Display Performance > High 

Quality Display. Next, choose open the Display Performance panel of InDesign’s Preferences dialog box and turn on “Preserve 

Object-level Display Settings.” Finally, make sure View > Display Performance > Allow Object-Level Display Settings is on.

resettIng a Pattern

If you make your pattern’s frame bigger, the pattern may no longer fill the entire frame. To force PatternMaker to fill the frame, 

click the Reset Pattern button in the palette. Be aware that this will undo any changes you’ve made to the embedded graphic 

itself, such as drop shadows, feathering, scaling, rotating, and so on. (It does maintain the effects applied to the frame itself, 

however.)

unembeDDIng Patterns

Patterns are actually EPS files embedded in your document. It’s rare that you would want to unembed one of these files, but if 

the need arises, you can easily do it using InDesign’s Links palette. (Just select the pattern and choose Unembed File from the 

Links palette menu). However, if you later make a change to the pattern, the new pattern file will be re-embedded. So if you 

want to unembed your patterns, you might want to wait until you’re done making your changes to the patterns before doing it.
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PrIntIng Patterns

When you print, you may see an aler t that says the file includes Binary EPS files. This is normal and you can click OK. (We 

suggest turning on the Do Not Show Again checkbox, so it doesn’t aler t you next time you print.)

Using Pattern Presets
PatternMaker allows you to save, edit and apply pattern presets.  A pattern preset lets you save all the settings in a pattern 

and then apply them all at once later.  Unlike styles in InDesign, pattern presets don’t stay linked after they’re applied.  In other 

words, updating the settings in a pattern preset will have no effect on the frames the preset has already been applied to.

Pattern presets exist either on the application workspace 

or the document workspace.  Presets that are created 

and edited when no documents are open are on the 

application workspace.  When a new document is 

created, the presets from the application workspace are 

copied to the document..

To work with presets when no documents are open, 

select the “Edit Presets...” menu from the PatternMaker 

flyout menu.

creatIng Pattern Presets from aPPlIeD Patterns

After applying a pattern to a frame and setting it up the way you’d like, you can then save that pattern as a preset through the 

“Save as preset...” option.  When you save a selection as a preset, you’ll be prompted for a name, and after you name it, you’ll 

be able to select the preset from the “Presets” dropdown in the PatternMaker palette.

You can choose  the “Save as preset...” option from two locations.  It is available from the flyout menu in the PatternMaker 

palette (see illustration above).  It is also available from the 

“Presets” dropdown list in the PatternMaker palette.

The PatternMaker flyout menu when nothing is selected.

The “Edit Preset...” and “Save as preset...” options are also 
available from the “Presets” dropdown list in the PatternMaker 
palette.
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WorkIng WIth Pattern Presets

Pattern presets can be created, edited, 

loaded or deleted by selecting “Edit 

Presets...” either from the PatternMaker 

flyout menu or from the preset dropdown 

list in the PatternMaker palette.  This will 

bring up the Pattern Presets dialog.

To delete presets, simply select the presets 

you wish to delete from the presets list and 

click the delete button.

To load presets from another document, 

click the load document and then navigate 

to the document that has the presets you 

wish to load.

To create a new preset, click the New 

button.  To edit an existing preset, select 

the preset you wish to edit and click the Edit button.  Both options will bring up the Edit Pattern Preset dialog, which we will 

discuss next..

C

D

E

F

A

B

The Edit Pattern Presets dialog.  A. List of available presets.  B. 
Summary of Preset settings. C. Create a new preset. D. Edit an existing 
preset. E. Delete selected presets. F. Load presets from another 
document.
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the eDIt Pattern Preset DIalog

The Edit Preset dialog lets you edit existing 

presets or create new presets from scratch.  You 

will use it to choose the name of the pattern 

preset, the pattern that the preset will apply, and 

all the parameters that the preset will use in the 

pattern.  When you select a different pattern, a 

different set of pattern parameters populate the 

dialog.

Pattern Catalog
PatternMaker comes with three patterns, and 

PatternPack adds an additional thir teen.  The 

following catalog describes all sixteen patterns 

that the plug-ins provide together...

The Edit Pattern Preset dialog.  A. The name of the Pattern Preset. B. 
The pattern that this preset uses. C. The pattern settings that are saved 
by the preset.

A

B

C
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concentrIc cIrcles

n Number of Circles – The number of circles evenly 
spaced from the inner radius to the size of your frame. 

n Inner Radius – The radius of the innermost circle.

n Stroke Weight – The thickness of each circle’s stroke

n Stroke Color – The color of the strokes circles

n Jitter – Whether the circles should be randomly offset 
from their centerpoints.

n Jitter Amount – If Jitter is on, then how much to allow 
each circle to offset from its centerpoint.

concentrIc cIrcles grID

n Shape Size – The size of the concentric circle shape. 

n Element Distance – The distance between the 
elements.

n Angle of The Grid – The angle the grid appears in the 
frame

n Num. of Circles – The number of circles in each grid 
element

n Inner Radius Size – The size of the radius of the 
innermost circle.

n Stroke Weight – The size of the stroke that define the 
circles

n Color . – The color of the concentric circle grid

crosses

n Cross Size – The size of each cross in the pattern

n Element Gap – The space between each cross in the 
pattern

n Pattern Angle – The angle that the pattern is rotated

n Shape Angle – The angle that each cross is rotated 
within its space on the grid.

n Stroke Weight – The thickness of the lines that make 
up the cross

n Stroke Color – The color of the crosses.

Dots

n Dot Size – The size of each dot in the pattern

n Element Gap – The space between each dot in the 
pattern

n Pattern Angle – The angle that the entire pattern is 
rotated

n Has Fill – Whether the dots are filled with a color

n Fill Color – The color the dots will be filled with

n Has Stroke – Whether each dot is encircled by a 
stroke

n Stroke Weight – The thickness of the encircling line

n Stroke Color – The color of the encircling line.

lInes

n Line Distance – The distance between each line in the 
pattern

n Angle – The angle at which the lines are slanted

n Iterations – How many times the pattern is repeated.  
For example, if you set Iterations to 3 and Angle to 
30 degrees, you’ll get one set of angles at 30 degrees, 
another at 60, and a third at 90.

n Stroke Weight – The thickness of the lines that make 
up the pattern.

n Dashes – If deselected, the lines making up this 
pattern are solid, unbroken lines.  If selected, then each 
line is broken up into a set of smaller dashes.

n Dash Length – The length of each dash making up an 
individual line. Only relevant if the “Dashes” checkbox 
is checked.

n Gap Length – The space between the dashes. Only 
relevant if the “Dashes” checkbox is checked.

n Random Dashes – If selected, then the dashes in each 
line do not line up but are randomly distributed. Only 
relevant if the “Dashes” checkbox is checked.

n Stroke Color – The color of the lines.
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ranDom lInes

n Random Seed – A “seed” in math terms allows 
random numbers to be reproduced.  So inputting a 
different number here will give you a different random 
distribution of lines, but if you find one random 
distribution you like, you can use it over and over 
again by using the same “seed” number.

n Box Size Offset – How far outside the frame the 
pattern’s lines may fall. Imagine that the random lines 
in this pattern are grouped together in a box. If the 
offset here is set to the minimum, .01, you’ll be able to 
see the whole box except .01 points along the edge. 

n Number Of Lines – How many lines are randomly 
drawn.

n Stroke Weight – The thickness of the lines in the 
pattern.

n Stroke Color – The color of the lines in the pattern.

ranDom V’s
n V Size – The size of the “V”s in the pattern.

n Gap Multiple – How far apart each “V” is from the 
other, defined as a percentage of the size of the shape.

n Closed Path – If checked, the “V”s become triangles.

n Pattern Angle – The angle of the full pattern in the 
frame.

n Has Stroke – If checked, a stroke will be drawn around 
each “V”.

n Stroke Weight – The thickness of the stroke around 
the “V”.  Has Stroke must be checked for this to have 
an effect.

n Stroke Color – The color of the stroke around the “V”.  
Has Stroke must be checked for this to have an effect.

n Has Fill – If checked, the “V”s will be filled with a color.

n Fill Color – The color of the fill in the “V”s.  Has Fill 
must be checked for this to have an effect.

scalloPs

n Scallop Type – There are three different scallop designs 
to choose from.

n Scallop Size – The size of each scallops in the pattern.

n Pattern Angle – The angle of the pattern in the frame.

n Stroke Weight – The thickness of the stroke within the 
scallop.

n Inner Stroke Pct – The weight of the inner stroke 
expressed as a percentage of the Stroke Weight field 
above. Only relevant for scallop type 2 and 3.

n Horizontal Scale – The horizontal scaling applied to 
the scallop shapes

n Color – The color of the scallops. 

sParkles

n Sparkle Size – The size of the sparkles in the pattern.

n Pattern Angle – The angle of the pattern in the frame.

n Stroke Weight – The thickness of the sparkles.

n Stroke Color – The color of the sparkles.
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sPIrals

n Spiral Shape – The type of shape that makes up the 
spiral

n Spiral Style – This number is used to in the equation 
that builds the spiral.  You can get all sorts of different 
spirals by experimenting with this field.  We’ve put a 
few cool styles into the dropdown, but feel free to 
type in your own and experiment!

n Spiral Density – How densely packed the shapes are 
that make up the spiral.

n Open Centered – Modifies the type of equation used 
to create the spiral. Unchecked, the spirals are more 
regular, with a dense center.  Checked, you get more 
curvy spirals with an open center.

n Shape Rotation – The rotation of the individual shapes 
that make up the pattern.

n Jitter Amount – This affects the individual shapes that 
make up the spiral. The higher the number, the more 
each shape may randomly rotate away from the 
curves of the spiral.

n Shape Size – The size of the individual shapes that 
make up the pattern.

n Color – The color of the pattern.

sQuares

n Square Size – The size of the squares.

n Element Gap – The space between each square in the 
pattern.

n Pattern Angle – The angle that the pattern is rotated 
within the frame.

n Shape Angle – The angle at which each square is 
rotated.

n Has Fill – Whether the squares are filled with a color.

n Fill Color – The color the squares will be filled with.

n Has Stroke – Whether each square is surrounded by a 
stroke.

n Stroke Weight – The thickness of the line around the 
square.

n Stroke Color – The color of the line around the 
square.

trIangles

n Triangle Size – The size of each triangle.

n Element Gap – The space between each triangle in 
the pattern.

n Pattern Angle – The angle that the pattern is rotated 
within the frame.

n Shape Angle – The angle at which each triangle is 
rotated.

n Has Fill – Whether the triangles are filled with a color.

n Fill Color – The color the triangles will be filled with.

n Has Stroke – Whether each triangle is surrounded by 
a stroke.

n Stroke Weight – The thickness of the line around the 
triangle.

n Stroke Color – The color of the line around the 
triangle.

WaVes

n Wave Length – The length of each individual wave 
(from one crest of the wave to the next).

n Wave Height – The height of each individual wave.

n Line Distance – The distance from one wavy line to 
the next.

n Angle – The angle of the pattern in the frame.

n Stroke Weight – The thickness of the lines in the wave.

n Stroke Color – The color of the waves.
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WeaVe

n Weave Size – The size of the individual elements in 
the weave.

n Number of lines – The number of lines making up the 
individual parts of the weave.

n Endlines – If checked, a line will be drawn at the end 
of each weave.

n Angle – The angle of the pattern in the frame.

n Line Weight – The thickness of the lines in the pattern.

n Line Color – The color of the lines in the weave.

n Endline Weight – The thickness of the lines at the end 
of each weave.

n Endline Color – The color of the lines at the end of 
each weave.

WIggles

n Wiggle Size – The average size of the individual 
elements in the pattern.

n Pattern Angle – The angle of the pattern in the frame.

n Stroke Weight – The weight of the individual wiggles.

n Stroke Color – The color of the wiggles.

ZIP coDe

n Zip Code – A five digit zip code.

n 4-Digit Suffix – An optional 4-code suffix to the zip 
code.



Simple, elegant solutions for Adobe InDesign

Page 12

Unexpected Patterns

Squares
size: 24 pt
gap: 14 pt
pattern angle: 45°
shape angle: 45°
Fill: Yes
Stroke: Yes

Dots
size: 24 pt
gap: 14 pt
pattern angle: 75°
Fill: Yes
Stroke: Yes

Triangles
size: 13 pt
gap: 11 pt
pattern angle: -45°
shape angle: 0°
Fill: Yes
Stroke: Yes, 5 pt

Crosses
size: 18 pt
gap: 10 pt
pattern angle: 0°
shape angle: 65°

Concentric
Circles
Circles: 100
Radius: 5
Stroke: .5 pt
Jitter : Yes
Jitter Amount: 50

Wiggles
size: 6
pattern angle: 45°
Stroke: 5 pt

Lines
aistance: 21 pt
angle: 2°
iterations: 150
stroke: .2 pt
dash: No

Lines
distance: 55 pt
angle: 1
iterations: 200
stroke weight: .25
dashes: Yes
dash length: 8 pt

Dots
size: 7 pt
gap: 10 pt
pattern angle: 45°
drop shadow
sheared: 61°
rotated: 61°

Scallops
type: 1
size: 20 pt
pattern angle: 45°
stroke weight: 2 pt
H-scale: 110%
drop shadow
sheared: 61°
rotated: 61°
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Scripting Guide
PatternMaker adds a single property and a single method to the PageItem object.  See the sample script that comes with 

BarcodeMaker to see how to script the plug-in.  The following table gives more information.

Patternmaker methoDs

These events and properties all exist on page items.  You can set a pattern by its name, and you can pattern parameters or 

individual properties.  See the demo JavaScript that installs with the plug-in to see these events and properties in action.  The 

script is called “PatternMakerParamsDemoScript.jsx”.

Name Parent Type Parameters Description

JavaScript: 
setPatternParam

VBScript: 
Set Pattern Param

AppleScript 
set pattern param

page item Event Name Type Description

paramName String, 
required

The name of the 
parameter to set

paramValue String, 
required

The value of the 
parameter.  “true” 
or “false” for 
boolean values, 
an integer for any 
measurements 
(always in points)

Sets the paramater of a 
pattern.  For example, for an 
ISBN barcode, parameters 
include “ISBN”, “Top font”, 
“Include text”, etc.  Type 
the name of the parameter 
exactly as it appears in the 
PatternMaker palette.

JavaScript and 
AppleScript: 
pattern

VBScript: 
Pattern

page item Property This is a String property.. Set this property equal to 
the pattern name to apply 
a pattern.  The pattern 
name should be exactly as it 
appears in the PatternMaker 
dropdown list of patterns.

JavaScript: 
patternParameters

VBScript: 
Pattern Parameters

AppleScript: 
pattern parameters

page item Property This is a string property describing all 
parameters in a given parameter in a single string 
of name value pairs.  Each pair is separated by 
a tilde (~) and names and values are separated 
by a colon (:).  So a typical pattern’s parameters 
might look like this:

EAN-2:10~Include text:true~Font:Verdana~Font 
style:Regular~Font size:10~Font 
position:0~Barcode Height:1~Ink Spread:0.15

Setting this property will 
set all parameters at once.  
it is much faster to use 
this property than to set 
parameters one at a time 
with SetPatternParam.



Simple, elegant solutions for Adobe InDesign

Page 14

Pattern Preset methoDs

The following preset methods operate on pattern presets, which can be found in a collection on either the document or the 

application.  See the demo JavaScript that installs with the plug-in to see these events and properties in action.  The script is 

called “PatternMakerPresetDemoScript.jsx”.

Name parent Type Parameters Description

JavaScript: 
setPreset

AppleScript  
set preset

VBScript: 
Set Preset

Page Item Event Name Type Description

preset name String, 
optional

The name of the 
preset

Applies a preset to a page 
item..

JavaScript: 
add

AppleScript  
make

VBScript: 
Add

Pattern 
preset 
collection 
on the 
document 
or 
workspace

Event Name Type Description

preset name String, 
optional

The name of the 
preset

Adds a new preset.  The 
pattern for the preset will 
default to the first pattern 
available.  You should make 
sure to set the pattern 
property on the preset 
immediately after creating 
the preset..

JavaScript 
remove

AppleScript: 
delete

VBScript: 
Delete

Pattern 
Preset

Event This is an event with no parameters Removes the preset from 
the collection in which it is 
contained.

JavaScript: 
setPatternParam

VBScript: 
Set Pattern Param

AppleScript 
set pattern param

Pattern 
Preset

Event Name Type Description

paramName String, 
required

The name of the 
parameter to set

paramValue String, 
required

The value of the 
parameter.  “true” 
or “false” for 
boolean values, 
an integer for any 
measurements 
(always in points)

Sets the paramater of a 
pattern.  For example, 
for an ISBN barcode, 
parameters include “ISBN”, 
“Top font”, “Include text”, 
etc.  Type the name of 
the parameter exactly 
as it appears in the 
PatternMaker palette.

JavaScript and 
AppleScriptt 
duplicate

VBScript 
Duplicate

Pattern 
Preset

Event Name Type Description

name String, 
optional

What to name 
the duplicate.  If 
omitted, will 
append the word 
“copy” to the 
existing preset 
name

Creates a duplicate of the 
preset
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Name parent Type Parameters Description

JavaScript: 
patternParameters

VBScript: 
Pattern Parameters

AppleScript: 
pattern parameters

Pattern 
Preset

Property This is a string property describing all 
parameters in a given parameter in a single 
string of name value pairs.  Each pair is 
separated by a tilde (~) and names and values 
are separated by a colon (:).  So a typical 
pattern’s parameters might look like this:

EAN-2:10~Include text:true~Font:Verdana~Font 
style:Regular~Font size:10~Font 
position:0~Barcode Height:1~Ink Spread:0.15

Setting this property will 
set all parameters at once.  
it is much faster to use 
this property than to set 
parameters one at a time 
with SetPatternParam.

JavaScript and 
ApplieScript: 
pattern

VBScript: 
Pattern

Pattern 
Preset

Property The preset’s pattern Setting this property will 
define what pattern is 
applied by the preset.

JavaScript and 
ApplieScript: 
name

VBScript: 
Name

Pattern 
Preset

Property The preset’s name This is the name of the 
preset, that appears in the 
presets dropdown in the 
PatternMaker palette and 
in the Edit Presets dialog
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Installing Your Teacup Plug-in
In order for InDesign to load a plug-in, it has to be in the “Plug-Ins” directory wherever you have InDesign installed.  You can 

put a plug-in anywhere underneath that directory, and InDesign will load it.

To install your Teacup plug-in, simply launch the installer.  It will place the plug-ins into your InDesign “Plug-ins” directory, along 

with any support files.

Activating Your Teacup Plug-In
When you purchase a Teacup plug-in, you are sent a serial 

number that you then use to activate the demo version to 

be the full working version.!

Please note that you must be logged in as an administrator 

to activate or purchase the plug-in.

actIVatIng usIng the Internet

1. There are two ways to star t the activation process
● From the plug-in’s splash screen, you can press 

the “Activate” button

● From the Help > About Plug-Ins menu (Win) or InDesign > About Plug-Ins menu (Mac), select Teacup > [plug-
in name] > Activate

2. A dialog will appear that has two sections to it.  In the first section, you enter your activation key.  In the second step, 

you click “Activate Automatically.”  This will connect with Teacup’s servers, check if the serial number is valid, and if it 

is, will unlock the plug-in.

3. When you’re finished activating, click the “Done” button to dismiss the dialog.

actIVatIng manually

Some networks have firewalls or proxies that don’t allow the plug-in to activate with Teacup’s servers.  To get around this, we 

offer a manual activation process.  To activate manually, follow all the steps outlined above, but before clicking on the “Activate 

Automatically” button, disconnect or deactivate your Internet connection.  The plug-in will detect that there is no connection, 

and a wizard will launch to allow you to manually activate.  The wizard will guide you through the process.

DeactIVatIng your teacuP Plug-In

If you want to move your plug-in from one machine to another one, you need to first deactivate the machine you have already 

activated.  To do this, go under Help > Deactivate Teacup Plug-in and select the plug-in you would like to deactivate.

The product activation dialog
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